1С8 сериализация объектов.

Простой пример xml сериализации объекта в 1с8.

1С8 сериализация объектов форма.
Скачать обработку (архив RAR) 1С8 сериализация объектов код.

В этом примере приведен простой код сериализация объектов.

Это две функции:
1. Получить xml файл из объекта
ПолучитьСериализациюОбъекта(СсылкаНаОбъект,ПутьКФайлу)
2. Получить объект из xml файла
ПолучитьОбъектИзXML(ПутьКФайлу)

Функция ПолучитьСериализациюОбъекта(СсылкаНаОбъект,ПутьКФайлу) Экспорт 
	
	// Создаем XML-класс для записи сериализуемого объекта в XML	
	ЗаписьXML = Новый ЗаписьXML;
	ЗаписьXML.ОткрытьФайл(ПутьКФайлу,"UTF-8"); 
	ЗаписьXML.ЗаписатьОбъявлениеXML();
	
	// Записываем объект, полученный из ссылки, в формат XML	
	Объект = СсылкаНаОбъект.ПолучитьОбъект();
	ЗаписатьXML(ЗаписьXML, СсылкаНаОбъект.ПолучитьОбъект(), НазначениеТипаXML.Явное);
	
	// Закрываем поток записи XML
	ЗаписьXML.Закрыть();	
	
КонецФункции


Функция  ПолучитьОбъектИзXML(ПутьКФайлу) Экспорт 

	ЧтениеXML = Новый ЧтениеXML;
	ЧтениеXML.ОткрытьФайл(ПутьКФайлу,,,"UTF-8"); 
	ДанныеXML = ПрочитатьXML(ЧтениеXML);
	
	типЗначения = ТипЗнч(ДанныеXML);
	стрТипЗначения = Строка(ТипЗнч(ДанныеXML));
		
	//ДанныеXML = ФабрикаXDTO.ПрочитатьXML(ЧтениеXML);
	
	Если ДанныеXML = Неопределено Тогда		
		Сообщить("Нет данных (или не верный формат) в Файле:" + ПутьКФайлу);   
		Возврат 0;                                    		
	Иначе
		Сообщить("Тип прочитали:" + строка(ДанныеXML) + "; тип:" + стрТипЗначения );  
	КонецЕсли;
		
КонецФункции

Скачать обработку (архив RAR)




Рекламный блок:

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

Доработка и сопровождение 1С:

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Пишите: j008@j008.ru

Звоните: 8 916 710 83 51 Ольга