1С8. Пример работы с Регистром сведений

Изменяем информацию в регистре сведений, если она там есть. Если нет - добавляем записи.


// корректируем Регистр сведений
Функция УстановитьПравоПользователя(
	Пользователь, 
	Право,
	ПравоЗначение
	)
		
	наборЗаписей = РегистрыСведений.ЗначенияДополнительныхПравПользователя.СоздатьНаборЗаписей();
	наборЗаписей.Отбор.Пользователь.Установить(Пользователь);
	наборЗаписей.Отбор.Право.Установить(Право);
	наборЗаписей.Прочитать();
	
	// если нет записей в отборе - добавим
	Если наборЗаписей.Количество() = 0  Тогда	 
		запись = наборЗаписей.Добавить();		
		комент = " - добавлена"; 
		
        	запись.Пользователь = Пользователь; 
        	запись.Право = Право; 
        	запись.Значение = ПравоЗначение;

	иначе	// если есть запись в отборе - изменим ее значение
	  
		наборЗаписей[0].Значение = ПравоЗначение; 		
		комент = " - обновлена"; 
	
	КонецЕсли;     	
	
	// Заготовка для нескольких записей
	//Для каждого строкаНаборЗаписей  Из наборЗаписей  Цикл		
	//	строкаНаборЗаписей.Значение = ПравоЗначение; 		
	//КонецЦикла;
		
	наборЗаписей.Записать();
	сообщить("" + Пользователь + " : " + Право + " : " +  ПравоЗначение +  " : " + комент);	
КонецФункции




Рекламный блок:

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

Доработка и сопровождение 1С:

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Пишите: j008@j008.ru

Звоните: 8 916 710 83 51 Ольга