1С8. Пример: Установить значение "показывать в списке выбора" пользователя базы.

Пример устанавливает для всех пользователей информационной базы, за исключением некоторых, "ПоказыватьВСпискеВыбора = Ложь".

1c не ПоказыватьВСпискеВыбора
Функция ПользователиИБ_УстановитьНеПоказыватьВСпискеВыбора()
	
	// получим массив всех пользователей информационной базы
	массПользовательИБ = ПользователиИнформационнойБазы.ПолучитьПользователей();
	
	// цикл по массиву
	для Каждого ПользовательИБ из массПользовательИБ цикл
		
		Роли  = ПользовательИБ.Роли;
		Админ = Роли.Содержит(Метаданные.Роли.Администрирование);
		
		//ПользовательИБ.	
		если Админ
			или ПользовательИБ.Имя = "Сисадминов Юрий Иванович"
			или ПользовательИБ.Имя = "Программистов Борис Борисович"
			тогда 
			сообщить("ПользовательИБ:" + ПользовательИБ.Имя + " : " 
				+ ПользовательИБ.ПоказыватьВСпискеВыбора + " - без изменения" );
			
			Продолжить;
			
		КонецЕсли;	  		
		
		ПользовательИБ.ПоказыватьВСпискеВыбора = Ложь;
		ПользовательИБ.Записать();
		сообщить("ПользовательИБ:" 
			+ ПользовательИБ.Имя + " : " 
			+ ПользовательИБ.ПоказыватьВСпискеВыбора + " : " 
			+ ПользовательИБ.ПользовательОС + " - V исправлено");
	КонецЦикла;	
		
	
КонецФункции

ПользователиИБ_УстановитьНеПоказыватьВСпискеВыбора();




Рекламный блок:

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

Доработка и сопровождение 1С:

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Пишите: j008@j008.ru

Звоните: 8 916 710 83 51 Ольга