1c8 пример. Поле документа html.

Простой пример кода, как программно открыть в поле ПолеHTMLДокумента страничку интернет - сайта.

Так выглядит результат:

Поле документа html

Объект ПолеHTMLДокумента работает в двух режимах: Просмотр (Browse)
Редактирование (Design)

Следует отметить, что свойство ПолеHTMLДокумента.Документ - это СОМ - объект HTMLDocument.

Этот COMОбъект предоставляет доступ к HTML документу, в соответствии со стандартом
World Wide Web Consortium (W3C) Document Object Model (DOM) Level 1
(http://www.w3.org/TR/2000/WD-DOM-Level-1-20000929/)
Реализован с помощью WebBrowser Control
http://msdn.microsoft.com/en-us/library/aa752040(VS.85).aspx
Тип свойства документ соотвествует типу HTMLDocument
http://msdn.microsoft.com/en-us/library/ms531073(VS.85).aspx

Так выглядит исходный код в Конфигураторе:

Поле документа html

Так выглядит код:

Поле документа html

Код примера:

// Размещаем на форме элемент ПолеHTMLдокумента
Процедура ОткрытьHTML()	
	
    Попытка
	ЭлементыФормы.ПолеHTMLДокумента.Перейти("http://ya.ru");
    Исключение
    КонецПопытки;
	            	
КонецПроцедуры  

Процедура КнопкаВыполнитьНажатие(Кнопка)
	
    текстHtml = ЭлементыФормы.ПолеHTMLДокумента.ПолучитьТекст();
    Сообщить(текстHtml);
КонецПроцедуры

Процедура ПриОткрытии()
    ОткрытьHTML();
КонецПроцедуры

Скачать код примера




Рекламный блок:

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

Доработка и сопровождение 1С:

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Пишите: j008@j008.ru

Звоните: 8 916 710 83 51 Ольга