1С8 Пример. Работаем с ftp сервером. Устанавливаем соединение, читаем каталог файлов.

Конструктор объекта ФТП = Новый FTPСоединение(...) в докуменетации имеет параметры:

FTPСоединение(<Сервер>, <Порт>, <ИмяПользователя>, <ПарольПользователя>, <Прокси>, <ПассивноеСоединение>, <Таймаут>).

Ниже две функции - ПолучитьFTPСоединение() и ПолучитьМассивФайловНаСайте(ФТП) демонстрирующие работу с FTP:

Функция ПолучитьFTPСоединение() 
	
	серверFTP = "89.111.111.1";	
	портFTP = 21;
	имяПользователяFTP = "userftp";
	парольПользователяFTP = "123456789"; 
	пассивноеСоединениеFTP = Истина;
	ПроксиFTP = null;
		
	
 	ФТП = Новый FTPСоединение(
		серверFTP,
		портFTP,
		имяПользователяFTP,
		парольПользователяFTP,
		ПроксиFTP,
		пассивноеСоединениеFTP
		);
	
	стрЛог = "";
	
	каталогFTP = мНастройки.каталогFTP;   		
	
	ФТП.УстановитьТекущийКаталог(каталогFTP);
	
	// заполнить глобальный массив именами файлов на сайте
	мФайлыНаFTP = ПолучитьМассивФайловНаСайте(ФТП);
	
	Возврат ФТП;
	
КонецФункции

// Замечание: Если в соединении FTP уже установлен каталог, то
// допонительно устанавливать его в методе ФТП.НайтиФайлы() не нужно.
Функция ПолучитьМассивФайловНаСайте(СоединениеФТП)
 	
	// Каталог оставляем пустым, так, как он уже задан при создании соединения	
	// иначе получим "Acces denied"
	каталогFTP = ""; 
	Маска="*";
	ИскатьВПодкаталогах = Ложь ;
	
	массивИменФайлов = СоединениеФТП.НайтиФайлы(каталогFTP, Маска, ИскатьВПодкаталогах) ;
	
	файлыНаFTP = новый массив;
	для каждого  файл  из массивИменФайлов цикл
		файлыНаFTP.Добавить(файл.Имя);
		стрЛог = стрЛог + файл.Имя + Символы.ВК;
	КонецЦикла;	
	
	соодщить("файлыНаFTP:" + файлыНаFTP.Количество() +  Символы.ВК + стрЛог);
		
	Возврат файлыНаFTP;
	
КонецФункции

No news availble