1С8 пример. Загружаем на форму изображение или картинки из файла.

Загружаем из файла (.jpg) изображение на элемент формы "поле картинки" (ЭлементыФормы.ИзображениеТовара).

Процедура ИзображениеТовараЗагрузить()
	
	// Открываем диалог - выбираем файл изображения
	Диалог = УниверсальныеМеханизмы.ПолучитьДиалогВыбораФайлов(Ложь);

	Если Не Диалог.Выбрать() Тогда
		Возврат;
	КонецЕсли;

	Попытка
		// Считываем данные изображения из файла
		Изображение = Новый ДвоичныеДанные(Диалог.ПолноеИмяФайла);
		
	Исключение
		Сообщить("" + ОписаниеОшибки());
	КонецПопытки;

	Если Изображение = "" Тогда
		Возврат;
	КонецЕсли;	

	// Загружаем изображение на элемент формы "поле картинки"
	ЭлементыФормы.ИзображениеТовара.Картинка = Новый Картинка(Изображение);

КонецПроцедуры




Рекламный блок:

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

Доработка и сопровождение 1С:

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Пишите: j008@j008.ru

Звоните: 8 916 710 83 51 Ольга