1С8 пример. Создаем таблицу значений Календарь .

1С8 пример. Создаем таблицу значений Календарь.

Функция создатьСтруктуруТЗКалендарь() Экспорт 
	мТЗКалендарь = Новый ТаблицаЗначений;
	
	// создаем описание типов данных колонок (полей) таблицы
	ТипДата = Новый ОписаниеТипов("Дата",,Новый КвалификаторыДаты);    
	ТипЧисло13   = Новый ОписаниеТипов("Число",,Новый КвалификаторыЧисла(13));
	
	// создаем нужные колонки. 
	мТЗКалендарь.Колонки.Добавить("ДатаДень",ТипДата); 
	мТЗКалендарь.Колонки.Добавить("ОстатокКоличество",ТипЧисло13);     
	
	// Добавим новую строку и зададим значения в колонках таблицы. 
	// НоваяСтрока = мТЗКалендарь.Добавить(); 
КонецФункции	

// Заполняет датами ТЗ в диапозоне [датаНачала,датаКонца]
Функция ЗаполнитьТЗКалендарь(датаНачала,датаКонца) Экспорт 
	
	мТЗКалендарь.Очистить();    	
	
	одиндень=86400;//60*60*24;//s  m  h
	
	тдата = датаНачала;
	
	Пока тдата <= датаКонца  Цикл
		
		тденьНедели  = ДеньНедели(тдата);
		
		// Субботу и воскресенье пропускаем - не учитываем
		Если тденьНедели = 6 или тденьНедели = 7  Тогда	 
			// пропускаем - не учитываем		
		иначе		
			НоваяСтрока = мТЗКалендарь.Добавить(); 	
			НоваяСтрока["ДатаДень"] = тдата;
			НоваяСтрока["ОстатокКоличество"] = 0;
		КонецЕсли;  	

		тдата = тдата + одиндень;
	КонецЦикла;
	
	сообщить("ЗаполнитьТЗКалендарь: мТЗКалендарь.Количество():" + мТЗКалендарь.Количество());
	
КонецФункции	

мОдинДень = 86400;//60*60*24;//s  m  h

создатьСтруктуруТЗКалендарь();




Рекламный блок:

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

Доработка и сопровождение 1С:

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Пишите: j008@j008.ru

Звоните: 8 916 710 83 51 Ольга