1С8 пример. Поиск по документам последней активности сотрудников.

В этом примере мы перемещаем сотрудников в папку уволенные по критерию. Критерий последняя "активность" сотрудника была 100 дней назад. Активность вычисляется запросом по документам "ЧекККМ", вернее по Регистру Сведений, куда пишет ЧекККМ - для более быстрой работы.

Функция ПолучитьРезультатЗапросаНеактивныепродавцы()
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	МАКСИМУМ(СтатистикаПродажПоЧекам.Период) КАК ДатаПоследнегоЧека,
		|	СтатистикаПродажПоЧекам.Продавец
		|ИЗ
		|	РегистрСведений.СтатистикаПродажПоЧекам КАК СтатистикаПродажПоЧекам
		|ГДЕ
		|	СтатистикаПродажПоЧекам.Период > ДОБАВИТЬКДАТЕ(&Сегодня, ДЕНЬ, -300)
		|	И СтатистикаПродажПоЧекам.Продавец В ИЕРАРХИИ(&ГруппаПродавцов)
		|	И НЕ СтатистикаПродажПоЧекам.Продавец.Родитель.Наименование ПОДОБНО &Dir
		|
		|СГРУППИРОВАТЬ ПО
		|	СтатистикаПродажПоЧекам.Продавец
		|
		|ИМЕЮЩИЕ
		|	МАКСИМУМ(СтатистикаПродажПоЧекам.Период) < ДОБАВИТЬКДАТЕ(&Сегодня, ДЕНЬ, -100)";
	//Параметры запроса
	Запрос.УстановитьПараметр("ГруппаПродавцов",Справочники.Пользователи.НайтиПоНаименованию("Продавцы"));// Пользователь
	Запрос.УстановитьПараметр("Сегодня",ТекущаяДатаСеанса());// Дата
	Запрос.УстановитьПараметр("Dir","Неприкосновенные%");// группа "Неприкосновенных" сотрудников, которых нельзя уволить. "Памятники" 
	
	ТаблицаНеактивныеПродавцы = Запрос.Выполнить().Выгрузить();   

	Возврат ТаблицаНеактивныеПродавцы;

КонецФункции //ПолучитьРезультатЗапроса_Неактивныепродавцы

Функция  ПеревестиНеактивныхПродавцоввПапкуУволенные(ТаблицаНеактивныепродавцы)
	
	для Каждого строка из ТаблицаНеактивныеПродавцы цикл
		Продавец = строка.Продавец.ПолучитьОбъект();
		Продавец.Родитель = Справочники.Пользователи.НайтиПоНаименованию("Уволенные");
		Продавец.Записать();
		
		сообщить("" + Продавец.Родитель + " : " + Продавец);
	КонецЦикла;	  	
    
КонецФункции

ТаблицаНеактивныеПродавцы = ПолучитьРезультатЗапросаНеактивныепродавцы();
ПеревестиНеактивныхПродавцоввПапкуУволенные(ТаблицаНеактивныепродавцы);




Рекламный блок:

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

Доработка и сопровождение 1С:

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Пишите: j008@j008.ru

Звоните: 8 916 710 83 51 Ольга