1С 8 пример. Как программно сохранить воссстановить настройки

В примере приведены функции сохранения и восстановления настроек.

Настройки в примере оформлены в виде структуры "ключ-значение". В качестве примера представлено сохранение/восстановление

структуры настроек в файл: ЗначениеВФайл(ФайлНастроек,мНастройки);

и непосредственно в базу 1С: СохранитьЗначение(ИмяНастроек, мНастройки); В какой регистр пишутся значения в этом случае ответить затруднительно. Скорее всего они доступны только через функции СохранитьЗначение(ИмяНастроек, мНастройки) и ВосстановитьЗначение(ИмяНастроек);

Функция СохранитьНастройки(мФайлНастроек)    
    ФайлНастроек = КаталогДокументов() + мФайлНастроек; //КаталогПрограммы()    
    мНастройки = новый Структура ;
    мНастройки = ЗаполнитьСтруктуруНастроекЗначениямиПоУмолчанию();     
    ЗначениеВФайл(ФайлНастроек,мНастройки);    
    ИмяНастроек = мФайлНастроек;
    СохранитьЗначение(ИмяНастроек, мНастройки);
КонецФункции           

Функция ЗаполнитьСтруктуруНастроекЗначениямиПоУмолчанию()
    мНастройки = новый Структура ;    

    мНастройки.Вставить("ImageMagick_HOME","C:\Program Files\ImageMagick-6.8.8-Q16\");        
    мНастройки.Вставить("server","89.111.111.11"); //"localhost";
    //мНастройки.Вставить("server","localhost");
    мНастройки.Вставить("user","user_site");
    мНастройки.Вставить("port","3306");
    мНастройки.Вставить("password","777");
    мНастройки.Вставить("database","dbname"); 
    Возврат мНастройки;
КонецФункции    

Функция ВосстановитьНастройки(мФайлНастроек)           
    ФайлНастроек = КаталогДокументов() + мФайлНастроек;    

    Попытка
        мНастройки = ЗначениеИзФайла(ФайлНастроек);        
    Исключение            

        //Если мНастройки.Количество() = 0 тогда        
        мНастройки = ЗаполнитьСтруктуруНастроекЗначениямиПоУмолчанию();
        СохранитьНастройки(мФайлНастроек);
        //КонецЕсли;    

    КонецПопытки;

    ИмяНастроек = мФайлНастроек;     
    мНастройки = ВосстановитьЗначение(ИмяНастроек);
    Возврат мНастройки;    
КонецФункции           

мФайлНастроек = "1C_ToSite.cfg";
ВосстановитьНастройки(мФайлНастроек);	   	

Так выглядит содержимое файла 1C_ToSite.cfg

Image




Рекламный блок:

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

Доработка и сопровождение 1С:

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Пишите: j008@j008.ru

Звоните: 8 916 710 83 51 Ольга