1С8. Пример как в справочнике изменить название элементов.

Простой пример, как в справочнике изменить название элементов.

Для примера будем изменять название элементов справочника Контрагенты. Во всех Наименованиях контрагентов будем искать символы кавычек (") и удалять их из Наименоваения. Наименование справочника перезапишем

  • Создаем выборку из элементов справочника Контрагенты.
  • Анализируем: Наименование содержит символ кавычек?.
  • Если содержит - удаляем кавычки, переприсваиваем. Записываем объект.
  • Результат

    1С8 Пример как в справочнике изменить название элементов
    // Пример изменения наименования элементов справочника Контрагентов
    Функция ИзменитьНзваниеЭлементовСправочникаКонтрагенты()
    	
    	// символ, который мы хотим удалить из наименования контрагента
    	спецсимвол = """"; // Символ двойная кавычка
    	
    	// Выборку получим напрямую без запроса (для упрощения примера)
    	// создаем выборку из всех элементов справочника номенклатуры
    	ВыборкаСправочникКонтрагенты = Справочники.Контрагенты.Выбрать();
    	
    	// перебираем вех контрагентов
    	Пока ВыборкаСправочникКонтрагенты.Следующий() Цикл		
    		
    		// текущий элемент выборки
    		элементКонтрагент = ВыборкаСправочникКонтрагенты;
    		
    		// наименование контрагента
    		КонтрагентНаименование = элементКонтрагент.Наименование;
    		
    		// логическая переменная (Истина/Ложь) содержит ли Наименование контрагента специальный символ 
    		НаименованиеСодержитСпецСимвол = ?(Найти(КонтрагентНаименование,спецсимвол),Истина,Ложь); 
    				
    		Если НаименованиеСодержитСпецСимвол Тогда 			
    			// если Наименование контрагента содержит специальный символ:
    			// удаляем из Наименования контрагента специальный символ
    			новоеНаименование = СтрЗаменить(КонтрагентНаименование,спецсимвол,"");
    			
    			// перед изменением в базе - фиксируем объект 
    			// (в базе будут установлены значения буферов записи, 
    			// соответствующие блокировки и начаты транзакции)
    			// получаем сам объект из ссылки (элементКонтрагент - это ссылка на объект)
    			КонтрагентОбъект = элементКонтрагент.ПолучитьОбъект();
    			
    			// изменяем значение поля Наименование справочника 
    			// (в буфере базы) на новое значение 
    			КонтрагентОбъект.Наименование = новоеНаименование;		
    			
    			// Записываем сделанные изменения объекта в базу.
    			// (Копируются значение буфера в базу - (update). Завершаются транзакции, 
    			// очищаются выделенные ресурсы, снимаются блокировки)
    			КонтрагентОбъект.Записать();
    			сообщить( КонтрагентНаименование + " -> " + КонтрагентОбъект.Наименование);
    
    		КонецЕсли;	
    	КонецЦикла;
    КонецФункции
    
    ИзменитьНзваниеЭлементовСправочникаКонтрагенты();
    	
    
    1С8 Пример как в справочнике изменить название элементов

    Результат

    1С8 Пример как в справочнике изменить название элементов

    


    Рекламный блок:

    Предлагаем решение Ваших задач 1С.

    Внедрение 1С:

    Доработка и сопровождение 1С:

    Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

    Пишите: j008@j008.ru

    Звоните: 8 916 710 83 51 Ольга