1С8. Пример получить html Document с товарами с яндекс маркет

Простой пример загрузки страницы с товарами с яндекс маркет.

Логика примера укладывается в два шага:

  • Создаем приложение InternetExplorer - функция ПолучитьAppIE().
  • В контексте приложения InternetExplorer Загружаем страницу по url - функция ПолучитьHtmlDoc().

В итоге получаем объектную модель (DOM) загруженного из интернета документа. Этот объект (COM) можно парсить, обрабатывать, разбирать и анализировать, например с помощью встроенных методов приложения IE или JavaScript и библиотеки jQuery.

// 
// Создаем новый пустой процесс приложения IE
// вернем указатель на процесс
Функция ПолучитьAppIE()	
	Попытка
		// создаем новый процесс приложения IE
		appIE = Новый COMОбъект("InternetExplorer.Application");
		appIE.Visible = Ложь; // не отображаем его (браузер) на экране		
	Исключение
		Сообщить("Ошибка создания приложения InternetExplorer.Application..."); 
	КонецПопытки;	
	Возврат appIE; // вернем указатель на процесс
КонецФункции

// Получаем объект DOMDocument с помощью приложения InternetExplorer.Application
Функция ПолучитьHtmlDoc(appIE,url)	
	Попытка	
		// загружаем страницу из интернета	
		appIE.Navigate(url);
		i=0;
		// ждем пока загрузится страница по url
		Пока appIE.Busy цикл
			i = i + 1;
			сообщить(i);
		КонецЦикла;	
		// получаем html-страницу как DOM (объектная модель документа)
		htmlDoc=appIE.Document;
        	//body = appIE.Document.getElementsByTagName("body");

	Исключение
		Сообщить("Ошибка создания документа html"); 	
	КонецПопытки;
	
	Возврат htmlDoc;

КонецФункции          

// загружаем страницу с товарами с яндекс маркет
Функция main();	
	
	// запрос на market.yandex.ru про редиску 
	url="http://market.yandex.ru/search.xml?text=%D1%80%D0%B5%D0%B4%D0%B8%D1%81%D0%BA%D0%B0&cvredirect=2";	
	
	// создаем новый процесс приложения IE
	appIE=ПолучитьAppIE();
	
	//DOMDocument с помощью приложения InternetExplorer.Application
	htmlDoc=ПолучитьHtmlDoc(appIE,url)	;
КонецФункции

main();
Пример_Массив_и_Временная_Таблица




Рекламный блок:

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

Доработка и сопровождение 1С:

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Пишите: j008@j008.ru

Звоните: 8 916 710 83 51 Ольга