1С8 Пример. Как Заполнить ФизическиеЛица в справочнике пользователей.

1С8 Пример. Как Заполнить ФизическиеЛица в справочнике пользователей..

Функция ВыборкаПользователиСПустымФизическимЛицом()    
    
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    |    Пользователи.Ссылка,
    |    Пользователи.Родитель,
    |    Пользователи.ЭтоГруппа,
    |    Пользователи.ФизЛицо,
    |    Пользователи.ФизическоеЛицо
    |ИЗ
    |    Справочник.Пользователи КАК Пользователи
    |ГДЕ
    |    Пользователи.ЭтоГруппа = &НЕ_Группа
    |    И Пользователи.Родитель В ИЕРАРХИИ(&Розница)    
    |    И Пользователи.ФизическоеЛицо = &ФизическоеЛицо";
    //Параметры запроса
    Запрос.УстановитьПараметр("НЕ_Группа",Ложь);// Булево
    ГруппаРозница = Справочники.Пользователи.НайтиПоНаименованию("Розница"); 
    Запрос.УстановитьПараметр("Розница",ГруппаРозница); // справочник Пользователь
    ПустаяСсылка=Справочники.ФизическиеЛица.ПустаяСсылка();
    Запрос.УстановитьПараметр("ФизическоеЛицо",ПустаяСсылка);// справочник Физические лица
    Результат = Запрос.Выполнить();
    
    Выборка = Результат.Выбрать();
    
    Возврат Выборка;

КонецФункции   

//
Функция УстановитьФизическиеЛица(Выборка)
    
    Пока Выборка.Следующий() Цикл
        //УстановитьФизическоеЛицо
        ФизическоеЛицо = Справочники.ФизическиеЛица.НайтиПоНаименованию(Выборка.Ссылка);
        Пользователь = Выборка.Ссылка.ПолучитьОбъект();        
        Пользователь.ФизическоеЛицо = ФизическоеЛицо;
        Пользователь.Записать();
        Сообщить("" + Пользователь + " " + Пользователь.ФизическоеЛицо + "-[ОК!]");
        
    КонецЦикла;

КонецФункции     

// основная логика
Функция ЗаполнитьФизическиеЛица()
    Выборка=ВыборкаПользователиСПустымФизическимЛицом();
    УстановитьФизическиеЛица(Выборка);
КонецФункции     

ЗаполнитьФизическиеЛица();