1С8 Как установить поле ОсновнойОтветственный

Пример. Пишем в РегистрыСведений.НастройкиПользователей. Этот пример актуален, если настройки пользователя хранятся в регистре сведений (РегистрыСведений.НастройкиПользователей).

// корректируем Регистр сведений
Функция УстановитьНастройкиПользователя(
    Пользователь, 
    Настройка,
    НастройкаЗначение
    )
    
    Пользователь = Справочники.Пользователи.НайтиПоНаименованию(Пользователь); 
    Настройка    = 
        ПланыВидовХарактеристик.НастройкиПользователей.НайтиПоНаименованию(Настройка);

    наборЗаписей = РегистрыСведений.НастройкиПользователей.СоздатьНаборЗаписей();
    наборЗаписей.Отбор.Пользователь.Установить(Пользователь);
    наборЗаписей.Отбор.Настройка.Установить(Настройка);
    наборЗаписей.Прочитать();
    
    Для каждого строкаНаборЗаписей  Из наборЗаписей  Цикл        
        строкаНаборЗаписей.Значение = НастройкаЗначение;         
    КонецЦикла;
    
    наборЗаписей.Записать();
    сообщить("" + Пользователь + " : " + Настройка + " : " +  НастройкаЗначение);    
КонецФункции

Функция ПолучитьВыборку_Пользователи()    
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    Пользователи.Ссылка как Пользователь,
    |    Пользователи.Родитель,
    |    Пользователи.ЭтоГруппа
    |ИЗ
    |    Справочник.Пользователи КАК Пользователи
    |ГДЕ
    |    Пользователи.ЭтоГруппа = &НЕ_Группа";
    //Параметры запроса
    Запрос.УстановитьПараметр("НЕ_Группа",Ложь);// Булево
    Результат = Запрос.Выполнить();
    
    Выборка = Результат.Выбрать();
    Возврат Выборка;
КонецФункции    

    
функция УстановитьОсновнойОтветственный(выборка)
        
    Пока Выборка.Следующий() Цикл
        Настройка=ПланыВидовХарактеристик.НастройкиПользователей.ОсновнойОтветственный;
        Пользователь=Выборка.Пользователь;
        НастройкаЗначение = Выборка.Пользователь;    
        
        рез = УстановитьПравоПользователя(
            Пользователь, 
            Настройка,
            НастройкаЗначение
            );        
    КонецЦикла;    

КонецФункции //ПолучитьРезультатЗапроса_Запрос1

// main
// Основная логика
// каждому пользователю установить значение ОсновнойОтветственный
// в регистре РегистрыСведений.НастройкиПользователей
выборка=ПолучитьВыборку_Пользователи();
УстановитьОсновнойОтветственный(выборка);