1С8. Пример работы с базой MySQL через {MySQL ODBC 5.1 Driver}


// Возвращает строку соединения с базой MySql
Функция ПолучитьConnectStringDB();
	
	server	= "89.111.222.33";      //"localhost";
	user 	= "username_MySQL";     // логин к базе mySql
	password= "password_MySQL";     // пароль к базе mySql
	database= "base_Name_MySQL";    // имя базы
	
	ConnectString="Driver={MySQL ODBC 5.1 Driver};" 
		+ "Server="    + server 
	 	+ ";Database=" + database
		+ ";User="     + user 
		+ ";Password=" + password
		+ ";Option=3;";      	
		
	msg("ConnectString:" + ConnectString);	
	
	Возврат ConnectString;
	
КонецФункции
                         

// Выполним sql выражение. Обработаем ошибки.
Функция ВыполнитьSQL(текстSQL);
	
	ConnectString=ПолучитьConnectStringDB();
	Connection = Новый COMОбъект("ADODB.Connection");
	Connection.open(ConnectString);	
	Попытка
		adCmdText_1 = 1;
		ss=Connection.Execute(текстSQL,,adCmdText_1);  
		Connection.Close();
		сообщить("Execute-[OK!]"); 
	Исключение            		

		Для каждого ADOErr из  Connection.Errors   Цикл
			сообщить("ERROR:" + Символы.ВК 
				+ текстSQL  			
				+ "Ошибка: " + ADOErr.Number 
				+ " : " + ADOErr.Description 	+ Символы.ВК
				+ " : " + ADOErr.Source 		+ Символы.ВК
				+ " : " + ADOErr.SQLState 		+ Символы.ВК
				+ " : " + ADOErr.NativeError 	+ Символы.ВК
				);			  	
				
		КонецЦикла;
                Connection.Close();

	КонецПопытки;	
		
	Возврат Неопределено;
	
КонецФункции


примерТекстSQL = "insert INTO fgn3k_virtuemart_products_ru_ru 
    |(
    |    product_name,  -- имя товара
    |    product_s_desc,/* описание товара */   
    |    slug        
    |) VALUES (
    |    ""product_name:Велосипед инженера Гарина"",
    |    ""product_s_desc:Металл: чугуний 
Цвет:розовый"", | ""slug:(2_псевдоним)"" |);"; ВыполнитьSQL(примерТекстSQL);