1C8 пример. Как раскрасить текст и фон ячеек табличной части (макета).

Пример как построчно раскрасить макет в 1с.

Image

1C8 пример кода:
// Пример раскраски текста и фона ячеек табличной части (макета) 
//
Функция РаскраситьМакет()
		
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ первые 100
	|	Банки.Наименование,
	|	Банки.Город
	|ИЗ
	|	Справочник.Банки КАК Банки";
	Результат = Запрос.Выполнить();
	
	ТабДокумент = Новый ТабличныйДокумент;
	ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_X";
	Макет       = ПолучитьМакет("Макет");
	
	ОбластьМакета = Макет.ПолучитьОбласть("Шапка");	
	ТабДокумент.Вывести(ОбластьМакета);

	
	ОбластьМакета = Макет.ПолучитьОбласть("Строка");
        цветной = 0;
	
	Выборка = Результат.Выбрать();
	Пока Выборка.Следующий() Цикл
		                             
		ОбластьМакета.Параметры.БанкНаименование=Выборка.Наименование;
		ОбластьМакета.Параметры.Город=Выборка.Город;
		
		//---- Раскраска начало				
		Область_ИмяЯчейкиДляРаскраски = ОбластьМакета.Область("Разукрашенная"); 
		
		Если цветной = 0 Тогда
			цветТекста = Новый Цвет(0, 0, 255); // синий 
			цветФона   = Новый Цвет(220, 220, 220); // фонистый
			цветной = 1;
		Иначе 
			цветТекста = Новый Цвет(255, 0, 0); // красный			
			цветФона   = Новый Цвет(255, 255, 255); // белый
			цветной = 0;
		КонецЕсли;   		
		
		Область_ИмяЯчейкиДляРаскраски.ЦветТекста = цветТекста;
		Область_ИмяЯчейкиДляРаскраски.ЦветФона   = цветФона;
		//---- Раскраска конец
		
		ТабДокумент.Вывести(ОбластьМакета);
	КонецЦикла;
    	
	Возврат ТабДокумент;
	
КонецФункции //ПолучитьРезультатЗапроса_Запрос1

Функция Печать() Экспорт
	ТабДокумент = РаскраситьМакет();
	возврат ТабДокумент;
КонецФункции

УниверсальныеМеханизмы.НапечататьДокумент(Печать());




Рекламный блок:

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

Доработка и сопровождение 1С:

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Пишите: j008@j008.ru

Звоните: 8 916 710 83 51 Ольга