1С8. Пример работы с текстовым файлом

Для организации работы с лог-файлом, казалось бы вполне достаточно объектов ЧтениеФайла() и ЗаписьФайла(). Но к сожалению, функция 1с ЗаписьФайла() не умеет добавлять строку в конец файла. А метод ДобавитьСтроку(строкаВФайл) объекта ТекстовыйДокумент прекрасно справляется с этим. Альтернативным решением этой задачи может быть использование объекта FSO.

Пример 1с записи строки в конец файла с помощью объекта FSO..
// Добавим запись в текстовый лог-файл
Функция ВЛогфайл(имяФайлаПолное, строкаВЛог) 
	
	// если имя файла пустое
	Если имяФайлаПолное = "" или строкаВЛог  = "" тогда		
    	    Возврат -1;
	КонецЕсли;
	
	// если указан файл без пути - назначим путь - каталог программы
	Если Найти(имяФайлаПолное, "\") = 0 тогда
    	имяФайлаПолное = КаталогПрограммы() + имяФайлаПолное;
	    сообщить("Лог:" + имяФайлаПолное);
	КонецЕсли;
	
	ТекстовыйДокумент = Новый ТекстовыйДокумент;
	кодировка = "UTF8" ;
	разделительСтрок = Символы.ВК + Символы.ПС; //Значение по умолчанию: ВК+ПС 
	                          	
	МассивФайлов = НайтиФайлы(имяФайлаПолное);		
		
	// если файл еще не создан добавим строку с именем файла
	Если МассивФайлов.Количество() = 0 тогда		
		ТекстовыйДокумент.ДобавитьСтроку(имяФайлаПолное);	
	иначе 
		// если файл с таким именем уже создан прочитаем его
		ТекстовыйДокумент.Прочитать(имяФайлаПолное,кодировка);			
	КонецЕсли;
	
	// добавим время к строке
	строкаВЛог = "[" + ТекущаяДата() + "] " + строкаВЛог; 
	// добавим строку в объект ТекстовыйДокумент
	ТекстовыйДокумент.ДобавитьСтроку(строкаВЛог);
	// закрываем ТекстовыйДокумент файл
	ТекстовыйДокумент.Записать(имяФайлаПолное,кодировка);
    
КонецФункции		

ВЛогфайл("C:\МойЛогФайл.txt","Это строка лога");




Рекламный блок:

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

Доработка и сопровождение 1С:

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Пишите: j008@j008.ru

Звоните: 8 916 710 83 51 Ольга