перем RegExp;

// Аргументы:
// строкаИмяФайла - имя файла без пути и расширения
// 
// Возвращает: 
// истина - Допустимое Имя Файла 
// ложь   - НЕ Допустимое Имя Файла 
//
// Пример:
// ДопустимоеИмяФайла("МоеИмяФайла_123") - 
// вернет "ложь"
Функция ДопустимоеИмяФайла(строкаИмяФайла)
	
	Если  ПустаяСтрока(СокрЛП(строкаИмяФайла)) Тогда	    
		//сообщить("Пустая");
		Возврат ложь;
	КонецЕсли;
	
	Если RegExp = Неопределено Тогда		
		
		сообщить("создаем RegExp");
		
		// создаем объект для работы с регулярными выражениями
		RegExp = Новый COMОбъект("VBScript.RegExp"); 
		
		// истина — текст многострочный, ложь — одна строка
		RegExp.MultiLine = ложь;  
		
		// истина — поиск по всей строке, ложь — до первого совпадения
		RegExp.Global = Истина; 
		
		// истина — игнорировать регистр строки при поиске
		RegExp.IgnoreCase = Истина; 
		 
		допустимоеИмяФайла = "([\W])"; //шаблон проверки 

		RegExp.Pattern = допустимоеИмяФайла; // шаблон (регулярное выражение)
		
	КонецЕсли; 

	Если RegExp.Test(строкаИмяФайла) Тогда	    
		Возврат ложь;
	КонецЕсли;
	
	Возврат Истина;

КонецФункции	




Рекламный блок:

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

Доработка и сопровождение 1С:

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Пишите: j008@j008.ru

Звоните: 8 916 710 83 51 Ольга