Роли, полные права пользователей. 1C8 Пример: Пользователи с ролью "Полные права". Запрос с ключевым словом "В ИЕРАРХИИ"

Ключевое слово "В ИЕРАРХИИ" в условии запроса 1С8, означает, выбрать во всех подчиненных группах (папках).

Запрос к справочнику Справочники.Пользователи. Роли, полные права пользователей. Пользователи с ролью "Полные права". Запрос с ключевым словом "В ИЕРАРХИИ".

// Пользователи с ролью "Полные права"
Функция ПолучитьВыборкуПользователи()
        
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    |    Пользователи.ВерсияДанных,
    |    Пользователи.Код,
    |    Пользователи.Наименование,
    |    Пользователи.ПометкаУдаления,
    |    Пользователи.Предопределенный,
    |    Пользователи.Представление,
    |    Пользователи.Родитель,
    |    Пользователи.Ссылка,
    |    Пользователи.ФизическоеЛицо,
    |    Пользователи.ФизЛицо,
    |    Пользователи.ЭтоГруппа    
    |ИЗ
    |    Справочник.Пользователи КАК Пользователи
    |// все пользователи в группе (папке) "Розница"      
    |ГДЕ Пользователи.Родитель В ИЕРАРХИИ (&Розница) //
    |И Пользователи.ЭтоГруппа = Ложь";
    //Параметры запроса:
    розница=Справочники.Пользователи.НайтиПоНаименованию("Розница");
    Запрос.УстановитьПараметр("Розница",розница);// 
    Результат = Запрос.Выполнить();    
    Выборка = Результат.Выбрать();
    
    Пока Выборка.Следующий() Цикл        
        ПользовательИмя = Выборка.Ссылка.Наименование;                
        ПользовательИБ = ПользователиИнформационнойБазы.НайтиПоИмени(ПользовательИмя);
        
        Если ПользовательИБ = Неопределено Тогда                                
            сообщить("" + ПользовательИмя + " - не зарегистрирован в ИБ!");        
        // назначена ли пользователю роль "ПолныеПрава"
        иначеЕсли ПользовательИБ.Роли.Содержит(Метаданные.Роли["ПолныеПрава"]) Тогда  
            сообщить("" + ПользовательИмя + " - [ПолныеПрава]");                        
        КонецЕсли;                                                        
    КонецЦикла;                  
    
    Возврат Выборка;
КонецФункции 

выборкаПользователи  = ПолучитьВыборкуПользователи();

Thursday, June 21, 2012

Замечание

Пользователи и Пользователи Информационной Базы хранятся в разных местах.

Wednesday, June 2, 2010

Роли - объект метаданных

Роли пользователя - объект метаданных




Рекламный блок:

Предлагаем решение Ваших задач 1С.

Внедрение 1С:

Доработка и сопровождение 1С:

Ориентировочная стоимость работ программиста 1С : 500 р. за 1 час работы.

Пишите: j008@j008.ru

Звоните: 8 916 710 83 51 Ольга